package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[^a-zA-Z0-9\\s]+`)
var str = `Test-Name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}