$re = '/(?<=[-+*\/^()])|(?=[-+*\/^()])/m';
$str = '-1+33+4.4+sin(3)-2-x^2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);