re = /^(?:[a-zA-Z][0-9]|[0-9][a-zA-Z]|[a-zA-Z]{2})[0-9]{6}$/m
str = 'AB123456
1A789563
A2547896
11111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end