$re = '/^(?![0-9]{2})[0-9a-zA-Z]{2}[0-9]{6}$/m';
$str = 'AB123456
1A789563
A2547896
11111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);