# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r" *; *"
test_str = "H;53; ;00 00 35.37;-29 15 48.2;10.96; ;H;000.14739023;-2.926.338.247; ; -1.76; 11.94; -12.96; 2.18; 1.03; 2.45; 3.15; 1.27; 0.03;-0.07; 0.07; 0.27; 0.05; 0.08;-0.10;-0.32; 0.11;-0.22;0; 1.19;53; ; ; ; ; ; ; ; ; ; ;T; ;111.006;0.0041;0.041;152; ;11.03;11.17; ; ; ; ; ; ; ;1; ; ; ; ; ; ; ; ; ; ;G; ; ; ;C-29 18916; ;0.72; ; "
subst = ";"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.