#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*\.v\n"
Local $sString = "ab." & @CRLF & _
"d" & @CRLF & _
"d" & @CRLF & _
"" & @CRLF & _
"b" & @CRLF & _
"c" & @CRLF & _
"d" & @CRLF & _
" /home/geli/Projects/coq/book-SoftwareFoundations/lf/ver5.3/lf:" & @CRLF & _
" total used in directory 6960 available 156637104" & @CRLF & _
" drwxr-xr-x 3 geli geli 28672 Oct 14 01:19 ." & @CRLF & _
" drwxrwxr-x 3 geli geli 4096 Sep 29 00:59 .." & @CRLF & _
" -rw-r--r-- 1 geli geli 4030 Sep 29 01:05 .Auto.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 27997 Sep 29 01:05 Auto.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 114710 Sep 7 00:46 Auto.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 231 Sep 29 01:05 .AutoTest.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 488 Sep 29 01:05 AutoTest.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 716 Sep 7 00:46 AutoTest.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 146 Sep 29 01:05 AutoTest.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 25563 Sep 29 01:05 AutoTest.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 21688 Sep 7 00:46 Auto.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 101 Sep 29 01:05 Auto.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 106413 Sep 29 01:05 Auto.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 7963 Sep 29 01:05 .Basics.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 25333 Sep 29 01:05 Basics.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 163893 Sep 7 00:46 Basics.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 1765 Sep 29 01:05 .BasicsTest.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 13920 Sep 29 01:05 BasicsTest.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 5495 Sep 7 00:46 BasicsTest.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 122 Sep 29 01:05 BasicsTest.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 2185 Sep 29 01:05 BasicsTest.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 49006 Oct 14 01:19 Basics.v" & @CRLF & _
" -rw-r--r-- 1 geli geli 48945 Sep 29 10:03 Basics.v~" & @CRLF & _
" -rw-rw-r-- 1 geli geli 73 Sep 29 01:05 Basics.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 33638 Sep 29 01:05 Basics.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 137 Sep 29 01:05 .Bib.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 45 Sep 29 01:05 Bib.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 3680 Sep 7 00:46 Bib.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 230 Sep 29 01:05 .BibTest.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 335 Sep 29 01:05 BibTest.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 552 Sep 7 00:46 BibTest.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 98 Sep 29 01:05 BibTest.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 2070 Sep 29 01:05 BibTest.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 1265 Sep 7 00:46 Bib.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 55 Sep 29 01:05 Bib.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 1253 Sep 29 01:05 Bib.vo" & @CRLF & _
" drwxr-xr-x 5 geli geli 4096 Sep 29 00:59 common" & @CRLF & _
" -rw-r--r-- 1 geli geli 245827 Sep 7 00:46 coqindex.html" & @CRLF & _
" -rw-rw-r-- 1 geli geli 90 Sep 29 01:02 _CoqProject~" & @CRLF & _
" -rw-rw-r-- 1 geli geli 72 Sep 29 01:04 _CoqProject.dist" & @CRLF & _
" -rw-r--r-- 1 geli geli 1886 Sep 7 00:46 .depend" & @CRLF & _
" -rw-r--r-- 1 geli geli 33848 Sep 7 00:46 deps.gif" & @CRLF & _
" -rw-r--r-- 1 geli geli 3552 Sep 7 00:46 deps.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 2058 Sep 7 00:46 deps.map" & @CRLF & _
" -rw-r--r-- 1 geli geli 144 Sep 29 01:05 .Extraction.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 437 Sep 29 01:05 Extraction.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 10550 Sep 7 00:46 Extraction.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 4506 Sep 7 00:46 Extraction.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 182 Sep 29 01:05 Extraction.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 25877 Sep 29 01:05 Extraction.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 4577 Sep 29 01:05 imp1.ml" & @CRLF & _
" -rw-r--r-- 1 geli geli 1255 Sep 29 01:05 imp1.mli" & @CRLF & _
" -rw-r--r-- 1 geli geli 4447 Sep 29 01:05 imp2.ml" & @CRLF & _
" -rw-r--r-- 1 geli geli 1200 Sep 29 01:05 imp2.mli" & @CRLF & _
" -rw-r--r-- 1 geli geli 7523 Sep 29 01:05 .Imp.aux" & @CRLF & _
" -rw-r--r-- 1 geli geli 1219 Sep 29 01:05 .ImpCEvalFun.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 13580 Sep 29 01:05 ImpCEvalFun.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 73635 Sep 7 00:46 ImpCEvalFun.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 12575 Sep 7 00:46 ImpCEvalFun.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 143 Sep 29 01:05 ImpCEvalFun.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 54914 Sep 29 01:05 ImpCEvalFun.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 993 Sep 7 00:46 impdriver.ml" & @CRLF & _
" -rw-rw-r-- 1 geli geli 64308 Sep 29 01:05 Imp.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 264297 Sep 7 00:46 Imp.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 100049 Sep 29 01:05 imp.ml" & @CRLF & _
" -rw-r--r-- 1 geli geli 3541 Sep 29 01:05 imp.mli" & @CRLF & _
" -rw-r--r-- 1 geli geli 1261 Sep 29 01:05 .ImpParser.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 40036 Sep 29 01:05 ImpParser.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 98096 Sep 7 00:46 ImpParser.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 13905 Sep 7 00:46 ImpParser.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 131 Sep 29 01:05 ImpParser.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 217451 Sep 29 01:05 ImpParser.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 62340 Sep 29 17:37 Imp.v" & @CRLF & _
" -rw-r--r-- 1 geli geli 62126 Sep 7 00:46 Imp.v~" & @CRLF & _
" -rw-rw-r-- 1 geli geli 76 Sep 29 01:05 Imp.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 128121 Sep 29 01:05 Imp.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 2532 Sep 7 00:46 index.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 2013 Sep 29 01:05 .IndPrinciples.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 7273 Sep 29 01:05 IndPrinciples.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 97705 Sep 7 00:46 IndPrinciples.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 241 Sep 29 01:05 .IndPrinciplesTest.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 448 Sep 29 01:05 IndPrinciplesTest.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 623 Sep 7 00:46 IndPrinciplesTest.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 215 Sep 29 01:05 IndPrinciplesTest.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 25719 Sep 29 01:05 IndPrinciplesTest.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 26206 Sep 7 00:46 IndPrinciples.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 152 Sep 29 01:05 IndPrinciples.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 44392 Sep 29 01:05 IndPrinciples.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 10063 Sep 29 01:05 .IndProp.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 47576 Sep 29 01:05 IndProp.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 246242 Sep 7 00:46 IndProp.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 56917 Sep 7 00:46 IndProp.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 102 Sep 29 01:05 IndProp.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 87009 Sep 29 01:05 IndProp.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 4092 Sep 29 01:05 .Induction.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 13616 Sep 29 01:05 Induction.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 52248 Sep 7 00:46 Induction.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 722 Sep 29 01:05 .InductionTest.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 6490 Sep 29 01:05 InductionTest.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 2779 Sep 7 00:46 InductionTest.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 171 Sep 29 01:05 InductionTest.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 2171 Sep 29 01:05 InductionTest.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 21215 Sep 7 00:46 Induction.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 116 Sep 29 01:05 Induction.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 8562 Sep 29 01:05 Induction.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 1043 Sep 7 00:46 LICENSE" & @CRLF & _
" -rw-r--r-- 1 geli geli 11086 Sep 29 01:05 .Lists.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 44766 Sep 29 01:05 Lists.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 153575 Sep 7 00:46 Lists.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 4028 Sep 29 01:05 .ListsTest.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 35332 Sep 29 01:05 ListsTest.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 10930 Sep 7 00:46 ListsTest.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 145 Sep 29 01:05 ListsTest.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 2351 Sep 29 01:05 ListsTest.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 35875 Sep 7 00:46 Lists.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 98 Sep 29 01:05 Lists.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 43108 Sep 29 01:05 Lists.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 13156 Sep 29 01:05 .Logic.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 45782 Sep 29 01:05 Logic.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 199398 Sep 7 00:46 Logic.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 2332 Sep 29 01:05 .LogicTest.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 33150 Sep 29 01:05 LogicTest.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 9562 Sep 7 00:46 LogicTest.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 141 Sep 29 01:05 LogicTest.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 3637 Sep 29 01:05 LogicTest.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 50242 Sep 7 00:46 Logic.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 94 Sep 29 01:05 Logic.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 75770 Sep 29 01:05 Logic.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 8464 Sep 7 00:46 Makefile" & @CRLF & _
" -rw-r--r-- 1 geli geli 3725 Sep 29 01:05 .Maps.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 11576 Sep 29 01:05 Maps.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 63258 Sep 7 00:46 Maps.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 371 Sep 29 01:05 .MapsTest.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 2993 Sep 29 01:05 MapsTest.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 1488 Sep 7 00:46 MapsTest.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 106 Sep 29 01:05 MapsTest.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 24201 Sep 29 01:05 MapsTest.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 12030 Sep 7 00:46 Maps.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 61 Sep 29 01:05 Maps.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 41736 Sep 29 01:05 Maps.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 11574 Sep 29 01:05 .Poly.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 47361 Sep 29 01:05 Poly.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 178578 Sep 7 00:46 Poly.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 3165 Sep 29 01:05 .PolyTest.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 29738 Sep 29 01:05 PolyTest.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 9007 Sep 7 00:46 PolyTest.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 129 Sep 29 01:05 PolyTest.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 2430 Sep 29 01:05 PolyTest.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 38772 Sep 7 00:46 Poly.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 84 Sep 29 01:05 Poly.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 67542 Sep 29 01:05 Poly.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 144 Sep 29 01:05 .Postscript.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 52 Sep 29 01:05 Postscript.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 6136 Sep 7 00:46 Postscript.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 237 Sep 29 01:05 .PostscriptTest.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 392 Sep 29 01:05 PostscriptTest.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 566 Sep 7 00:46 PostscriptTest.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 154 Sep 29 01:05 PostscriptTest.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 2098 Sep 29 01:05 PostscriptTest.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 3655 Sep 7 00:46 Postscript.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 97 Sep 29 01:05 Postscript.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 1267 Sep 29 01:05 Postscript.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 141 Sep 29 01:05 .Preface.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 49 Sep 29 01:05 Preface.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 23910 Sep 7 00:46 Preface.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 234 Sep 29 01:05 .PrefaceTest.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 368 Sep 29 01:05 PrefaceTest.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 560 Sep 7 00:46 PrefaceTest.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 130 Sep 29 01:05 PrefaceTest.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 2086 Sep 29 01:05 PrefaceTest.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 19921 Sep 7 00:46 Preface.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 79 Sep 29 01:05 Preface.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 1261 Sep 29 01:05 Preface.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 2500 Sep 29 01:05 .ProofObjects.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 10291 Sep 29 01:05 ProofObjects.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 71057 Sep 7 00:46 ProofObjects.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 21209 Sep 7 00:46 ProofObjects.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 136 Sep 29 01:05 ProofObjects.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 40133 Sep 29 01:05 ProofObjects.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 646 Sep 7 00:46 README" & @CRLF & _
" -rw-r--r-- 1 geli geli 3137 Sep 29 01:05 .Rel.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 12825 Sep 29 01:05 Rel.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 65837 Sep 7 00:46 Rel.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 12721 Sep 7 00:46 Rel.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 82 Sep 29 01:05 Rel.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 41219 Sep 29 01:05 Rel.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 6984 Sep 29 01:05 .Tactics.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 30916 Sep 29 01:05 Tactics.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 170622 Sep 7 00:46 Tactics.html" & @CRLF & _
" -rw-r--r-- 1 geli geli 864 Sep 29 01:05 .TacticsTest.aux" & @CRLF & _
" -rw-rw-r-- 1 geli geli 11356 Sep 29 01:05 TacticsTest.glob" & @CRLF & _
" -rw-r--r-- 1 geli geli 4193 Sep 7 00:46 TacticsTest.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 151 Sep 29 01:05 TacticsTest.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 2360 Sep 29 01:05 TacticsTest.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 38414 Sep 7 00:46 Tactics.v" & @CRLF & _
" -rw-rw-r-- 1 geli geli 100 Sep 29 01:05 Tactics.v.d" & @CRLF & _
" -rw-rw-r-- 1 geli geli 25778 Sep 29 01:05 Tactics.vo" & @CRLF & _
" -rw-r--r-- 1 geli geli 17052 Sep 7 00:46 toc.html" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")