$re = '/(?<!0)(00)+$/m';
$str = '0
1
100
000
0000
1000
10010000
100100000
1001000000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);