package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(a)?(b)?(c)?$`)
var str = `
a
ab
ac
bc
c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}