$re = '/^\d+?0?(?=(?:00)*$)/m';
$str = '12345678
12345600
12345000
12003000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);