const regex = new RegExp('(?<=\\s)\\S+\\s\\[!at\\]\\s\\S+\\.\\S+', 'gm')
const str = `If you have any questions or concerns, you may contact us at kaieldentsome [!at] gmail.com. You can also follow us on fb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}