$re = '/(<[^>]*?href\s*=\s*[\'"](?![^\'"]*mp3))[^\'"]*/';
$str = '<a href=\'http://example.com\'>click here</a>
<a href=\'http://example.com/test.mp3\'>the site</a>';
$subst = "\1http://myotherexample.com";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;