$re = '/^[^;].*[;,)%&@]/s';
$str = 'Stack;O&verflow;i%s;the;best!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);