const regex = /^#(\d+)\s*=\s*([a-zA-Z0-9]+)\s*\(((?:'[^']*'|[^;'])+)\);/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^#(\\d+)\\s*=\\s*([a-zA-Z0-9]+)\\s*\\(((?:\'[^\']*\'|[^;\'])+)\\);', 'gim')
const str = `#1=IFCOWNERHISTORY(#89024,#44585,\$,.NOCHANGE.,\$,\$,\$,1190720890);
#2=IFCSPACE(';;);',#1,\$);some text);
#2=IFCSPACE(';;);',#1,\$);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}