use strict;
my $str = 'https//example.com';
my $regex = qr`\bhttps?\K(?=//)`mp;
my $subst = ':';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";