$re = '/^.{1,5}$/m';
$str = '12345
1234
123
12
1
123456
1234567
123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);