# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d{4}-\d{2}-\d{2}"
test_str = ("2020 \n"
"2019/10/16\n"
"2020/08/12 \n"
"31/01/2020 \n"
"2020-11-03 \n"
"05/01/2020 \n"
"04/17/2020 \n"
"2019/12/31 \n"
"2021-07-14\n"
"2019/12/04 \n"
"2010/12/16 \n"
"2021 \n"
"04/03/2020 \n"
"4/30/2020\n"
"2011/07/18 \n"
"2017/06/20 \n"
"2019 \n"
"2021-10-13 \n"
"2020\n"
"2021-07-14 \n"
"2021/11/08 \n"
"2020-11-03 \n"
"2021 \n"
"2019/12/31\n"
"2019-12-04 \n"
"null\n"
"2020/01/04")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.