$re = '/\s[-+\/*](?!.*\s[-+\/*])/';
$str = '2 + 5 + 8e+d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);