$re = '/^.{4}\$.\$.+/m';
$str = 'xxxx$x$xxxxx would match
xx$x$xxxxxxx would not';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);