$re = '/[A-Z0-9\-\s]{6,7}/m';
$str = '97 995';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);