$re = '/(\d+[x. ]+)(\d+)/';
$str = 'total 19xx.100
total 19x..100
total 19..100
total 19x .100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);