package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d`)
var str = `hello 1 world_2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}