import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\D*(\\d)\\D*(\\d)\\D*$";
final String string = "Z189\n"
+ "I142\n"
+ "M395\n"
+ "L210\n"
+ "V467\n"
+ "M203\n"
+ "Q277\n"
+ "Q461\n"
+ "Y440\n"
+ "S250\n"
+ "M162\n"
+ "Q96\n"
+ "22Q\n"
+ "W148\n"
+ "Q72\n"
+ "T22T\n"
+ "22TWE22\n"
+ "12E34";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}