$re = '/\p{L}/m';
$str = 'łąka123!@#$%^&*()_+ñ/Ñ, "í".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);