re = /^\s*([+-]?((0|[1-9][0-9]*)(\.[0-9]*)?|\.[0-9]+)([Ee][+-]?[0-9]+)?)\s*$/m
str = '-3.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end