import re
regex = re.compile(r"(?<=[.?!](?! [a-z0-9]))(?<!-Sgt\.) ", flags=re.MULTILINE)
test_str = ("I am from New York, N.Y. and I would like to say hello! How are you today? I am well. I owe you $6. 00 because you bought me a No. 3 burger. -Sgt. Smith\n")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)