$re = '/(?>^|(?<=[\s-\.\'])) (\w)/xu';
$str = 'ZAN ROAD HOG HEADWRAPS The most popular ZAN headwrap style-features custom and original artwork
La dernière usine française d\'accordéons reste à Tulle';
$subst = "-- ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;