$re = '/^.*, (.*)$/';
$str = '43 Millcourt Avenue, Clondalkin, Dublin 22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);