re = /^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&*()-_+=;:,.\/?\|`~{}])(?=\S+$).{8,}$/m
str = 'sA12_+'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end