package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\/`)
var str = `https://skyfire.vimeocdn.com/1485599447-0xf546ac1afe7bce06fa5153973a8b85b1c45051d3/159463108/video/499604330/playlist.m3u8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}