import Foundation
let pattern = #"<([^\/>]+)>((([^\<]+)|(?R))*)<\/\1>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = ##"""
<ul><li><span>qwe</span><b></b></li><div>sometext</div></ul><div></div>.
<li><span>qwe</span><div>s</div></li>
<b></b>
<ul><li><span>qwe</span><b></b></li><div>sometext</div></ul><div></div>.
some text <tag>some|another|text</tag> and anything else
str = <<'EOT'
Это <!--пример текста--> с5
<a href="#">какой-то</a> <br>разметкой <br />
<b class="11">и</b> <amg src="1">
<area>непарными</area> <strong>
тегами</strong> и, <!--коментами-->,
<ul id="w"> <li id="id" class="class">1</li></ul><div></div>.
<u class="ну и даже так" />
EOT
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)