$re = '/(?:[A-Z]*\s*)(\d+)((.|,)(\d+))?/m';
$str = 'H 24
5,56
81
240,60
L 201';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);