package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\bводит([\w]+)?`)
var str = `Водитель водит водителя предводителя`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}