import re
regex = re.compile(r"(^[A-Za-z0-9 \"]*)(\<sip:)([\+1]*8004001506)(.*\>.*)", flags=re.MULTILINE)
test_str = "\"WIRELESS CALLER\" <sip:+18004001506@192.168.18.40;isup-oli=62>;tag=gK0461bc7f"
subst = "\\\"Company A\\\" \\2\\3\\4"
result = regex.sub(subst, test_str)
if result:
print(result)