re = /([a-z\.]+):\d/mi
str = '9 40 0.5752 2 0.0000 *BRK.B:23.42:24.08:-2.82% PFE:28.05:26.94:3.97%
9 40 0.5752 2 0.0000 *NOV:23.42:24.08:-2.82%
3 50 0.5752 7 0.0000 C:23.42:24.08:-2.82% *AAPL:28.05:26.94:3.97%% *MMM:28.05:26.94:3.97%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end