re = /\b(?<!\.)\d{1,2}[\/-]\d+[\/-]\d{2,4}\b/
str = 'Lithium 0.25 (7/11/77). LFTS wnl. Urine tox neg. Serum tox + fluoxetine 500; otherwise neg. TSH 3.28. BUN/Cr: 16/0.83. Lipids unremarkable. B12 363, Folate >20. CBC: 4.9/36/308 Pertinent Medical Review of Systems Constitutional:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end