import Foundation
let pattern = #"(?<![=|\|]) *(?:\{\{)*(\d+)(?:(?:\{\{)*(er)(?:\}\})*)* *(janvier|f[ée]vrier|mars|avril|mai|juin|juillet|a[ôo][ûu]t|septembre|octobre|novembre|d[ée]cembre) *(\d{3,4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
1er mars 2020
{{1er}} mars 2020
1{{er}} mars 2020
1 mars 2020
20 mars 2020
I don't want these ones:
date= 20 Mars 2025
date=20 Mars 2025
{{date|20 aout 2020}}
{{date| 20 aout 2020}}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{{date|$1$2 $3 $4}}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)