import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "('http.*?')";
final String string = "'http://mediafile.cloud/b34b4f6720a31f73?pt=UkhBMmVHczFaRXA2Uld4ek1qYzVWME5DYzNodVFUMDlPampsTkQ5aFNpVWxQamVlZ3REQkpEdz0%3D'\n"
+ "'https://mediafile.cloud/b34b4f6720a31f73?pt=UkhBMmVHczFaRXA2Uld4ek1qYzVWME5DYzNodVFUMDlPampsTkQ5aFNpVWxQamVlZ3REQkpEdz0%3D'\n"
+ "'http://www.mediafile.cloud/b34b4f6720a31f73?pt=UkhBMmVHczFaRXA2Uld4ek1qYzVWME5DYzNodVFUMDlPampsTkQ5aFNpVWxQamVlZ3REQkpEdz0%3D'\n"
+ "'https://www.mediafile.cloud/b34b4f6720a31f73?pt=UkhBMmVHczFaRXA2Uld4ek1qYzVWME5DYzNodVFUMDlPampsTkQ5aFNpVWxQamVlZ3REQkpEdz0%3D'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}