# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:https?:\/\/)?(?:[^@\/\n]+@)?(?:www\.)?([^:\/\n]+)/?$"
test_str = ("https://play.google.com/store/apps/details?id=com.skgames.trafficracer%22\n"
"http://mplay.google.co.in/sadfask/asdkfals?dk=10\n"
"http://lplay.google.co.in/sadfask/asdkfals?dk=10\n"
"http://play.google.co.in/sadfask/asdkfals?dk=10\n"
"http://tplay.google.co.in/sadfask/asdkfals?dk=10\n"
"http://www.google.co.in/sadfask/asdkfals?dk=10\n"
"www.google.co.in/sadfask/asdkfals?dk=10\n"
"http://user:pass@google.com/?a=b#asdd\n"
"https://play.google.com/\n"
"http://mplay.google.co.in\n"
"http://lplay.google.co.in\n"
"http://play.google.co.in\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.