#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<=EFFRG=).*(?=><\/EFFECT>))"
Local $sString = "<SBDATA>" & @CRLF & _
"<SBNRMFR>" & @CRLF & _
"<SBNBR>31A0179</SBNBR>" & @CRLF & _
"<MFR>81205</MFR>" & @CRLF & _
"</SBNRMFR>" & @CRLF & _
"<MDNRMFR>" & @CRLF & _
"<MDNBR>BB31A0179</MDNBR>" & @CRLF & _
"<MFR>81205</MFR>" & @CRLF & _
"</MDNRMFR>" & @CRLF & _
"<ICS>SEP 5/16</ICS>" & @CRLF & _
"</SBDATA>" & @CRLF & _
"<ITEM CHAPNBR=""23" SECTNBR="31" UNITNBR="03" FIGNBR="10B" ITEMNBR="002K" ILLUSIND="0" INDENT="1" ATTACH="0" CHG="U" KEY="K23310310B002K" REVDATE="20200905"><EFFECT EFFRG="101200"></EFFECT><PNRMFR><PNR>413W1310-101B</PNR><MFR>81205</MFR></PNRMFR><UPA>RF</UPA>" & @CRLF & _
"<TQA>AR</TQA>" & @CRLF & _
"<ADT>OVERDOOR (PASSENGER ADDRESS SYSTEM ONLY)</ADT>" & @CRLF & _
"<LBL>&PLD;</LBL>" & @CRLF & _
"<PLD>SECT. 41 LH</PLD>" & @CRLF & _
"<LBL>&NH2;</LBL>" & @CRLF & _
"<REFINT REFID="K25210810B" REFTYPE="NH2">25-21-08-10B</REFINT>" & @CRLF & _
"</ITEM>" & @CRLF & _
"<AIPC MODEL="777-200/300" OIDATE="19951005" REVDATE="20200905" TSN="107" DOCNBR="D633W111" CUS="EAD" CHG="R" LANG="EN" CUSNAME="EMIRATES" SPL="81205"><TITLE>AIRCRAFT ILLUSTRATED PARTS CATALOG</TITLE><MFMATR><INTRO CHG="U" KEY="INTRO" REVDATE="20200905">" & @CRLF & _
"<TITLE>INTRODUCTION</TITLE>" & @CRLF & _
"<PARA></PARA>" & @CRLF & _
"<TITLE>PURPOSE</TITLE>" & @CRLF & _
"<PARA></PARA><PARA>This document is prepared, issued and revised by Boeing for the exclusive use of its customers and is intended for use in provisioning, requisitioning, storing, and issuing line replaceable aircraft parts and units and in identifying maintenance significant parts. The content of this document is proprietary to Boeing and its customers and is subject to change. The use of any part of this document by any other person or persons for any other purpose without written consent of Boeing is expressly prohibited. In addition, Boeing expressly disclaims any and all responsibility arising from or in any way related to any such use without Boeing's prior written consent thereto. This document is produced to support the configuration of the aircraft at the time of delivery to the original customer and changes submitted by the customer after delivery. It does not necessarily reflect the current configuration of any specific aircraft.</PARA>" & @CRLF & _
"<PARA></PARA><PARA>The part number content, associated data elements, functional arrangement and breakdown sequence of items contained within this document is produced in accordance with the Air Transport Association (ATA) Specification No. 100. The document requirements in ATA Spec 100 were combined with ATA 2100 to form iSpec 2200 in year 2000. iSpec 2200 defines industry requirements for technical data, digital data transmission, Document Type Definitions (DTD's), and the Common Support Data Dictionary (CSDD) definitions of the data elements.</PARA>" & @CRLF & _
"<PARA></PARA><PARA>Illustrated Parts Catalog (IPC)/Illustrated Parts Data (IPD) data is available in industry standard, Standard Generalized Markup Language (SGML) in accordance with ATA iSpec 2200. The IPC/IPD is not available in S1000d format.</PARA>" & @CRLF & _
"<PARA></PARA><PARA>Air Transport Association has been renamed Airlines 4 America (A4A). For additional information or to acquire a copy of any ATA / A4A Specification please contact the following for ordering information:</PARA>" & @CRLF & _
"<PARA></PARA><PARA>Airlines 4 America (A4A) Phone: 1-202-626-4062 e-mail: pubs@airlines.org Internet Address: www.airlines.org</PARA>" & @CRLF & _
"<PARA></PARA>" & @CRLF & _
"<TITLE>GENERAL SYSTEM OF ASSEMBLY ORDER-DETAILED PARTS LIST (DPL)</TITLE>" & @CRLF & _
"<TXTGRPHC><TXTLINE>" & @CRLF & _
"</TXTLINE>" & @CRLF & _
"<TXTLINE>The indenture system used in the Parts Lists of the figures" & @CRLF & _
"</TXTLINE>" & @CRLF & _
"<TXTLINE>included within this catalog shows the relationship of one part" & @CRLF & _
"</TXTLINE>" & @CRLF & _
"<TXTLINE>to another. For a given item, the number of indentures defines" & @CRLF & _
"</TXTLINE>" & @CRLF & _
"<TXTLINE>the relationship of the item to the associated installation, next" & @CRLF & _
"</TXTLINE>" & @CRLF & _
"<TXTLINE>higher assembly, or components of the item as follows:" & @CRLF & _
"</TXTLINE>" & @CRLF & _
"<TXTLINE>" & @CRLF & _
"</TXTLINE>" & @CRLF & _
"<TXTLINE>1234567" & @CRLF & _
"</TXTLINE>" & @CRLF & _
"<TXTLINE>Installation" & @CRLF & _
"</TXTLINE>" & @CRLF & _
"<TXTLINE>.Detail Parts for Installation" & @CRLF & _
"</TXTLINE>" & @CRLF & _
"<TXTLINE>.Assembly" & @CRLF & _
"</TXTLINE>" & @CRLF & _
"<TXTLINE>.Attaching Parts for Assembly" & @CRLF & _
"</TXTLINE>" & @CRLF & _
"<ITEM CHAPNBR="25" SECTNBR="85" UNITNBR="00" FIGNBR="10A" ITEMNBR="390K" ILLUSIND="1" INDENT="2" ATTACH="0" CHG="U" KEY="K25850010A390K" REVDATE="20200905"><EFFECT EFFRG="003100"></EFFECT><PNRMFR><PNR>415W0116-237</PNR><MFR>81205</MFR></PNRMFR><UPA>1</UPA>" & @CRLF & _
"<TQA>AR</TQA>" & @CRLF & _
"</ITEM>" & @CRLF & _
"<ITEM CHAPNBR="25" SECTNBR="85" UNITNBR="00" FIGNBR="10A" ITEMNBR="395" ILLUSIND="1" INDENT="2" ATTACH="0" CHG="U" KEY="K25850010A395" REVDATE="20200905">" & @CRLF & _
"<EFFECT EFFRG="003100">" & @CRLF & _
"</EFFECT>" & @CRLF & _
"<PNRMFR><PNR>415W0110-241</PNR>" & @CRLF & _
"<MFR>81205</MFR>" & @CRLF & _
"</PNRMFR>" & @CRLF & _
"<UPA>1</UPA>" & @CRLF & _
"<TQA>AR</TQA>" & @CRLF & _
"</ITEM>""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")