using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https://)?(www\.)?(instagram\.com)?/?[\w.]+/?$";
string input = @"https://www.instagram.com/lceymard/
lceymard/
/lceymard/
instagram.com/lceymard
instagram.com/lceymard/
www.instagram.com/lceymard
www.instagram.com/lceymard/
https://www.instagram.com/lceymard
https://www.instagram.com/lceymard/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}