const regex = /value="([^"]+)".+?ip_h:\s*'(\1)'/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('value="([^"]+)".+?ip_h:\\s*\'(\\1)\'', 'gms')
const str = `1. name="ip_h" value="658c9f771e0ceb7сс1" />
2. ip_h: '658c9f771e0ceb7сс1',`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}