re = /^(?<noextension>\w+)$|(?<filename>\w+(?:\.\w+)*)\.(?<extension>\w+)$/m
str = 'foo.baz.bing.bong
one.two
noextension
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end