// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\S]*(?:\[%)(\w+)(?:%])(?:(?:[^\S\n]*=[^\S\n]*([^\n]*[\S])))?").unwrap();
let string = "[%Variable%]
[%Another_One%] = Lots of characters but no trailing spaces
[%MoreVariables_44%] = NotWhiteSpace Sensistive
[%NoBlanksAllowed%] = ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}