use strict;
my $str = '561616161
121212123
411111111
111111114
111111111
299887766
887756564
123412345
123123123
934343434
934343435
934345634';
my $regex = qr/^(?=\d{9}$)\d*((\d)(?!\2)\d)\1{3}\d*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}