$re = '/Return-Receipt-To: Shawn Hanson (?!<shawn\.hanson@marinecu\.com>)/m';
$str = 'Return-Receipt-To: Shawn Hanson <pres@exec-mail.net>
Return-Receipt-To: Shawn Hanson <shawn.hanson@marinecu.com>
Return-Receipt-To: Shawn Hanson <shawn.hanson@marinecu.com>
Return-Receipt-To: Shawn Hanson <shawn.hanson@marine.com>
Return-Receipt-To: Shawn Hanson <shawn.hanson@gmail.com>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);