$re = '/([A-Za-z])(?=(?:.*\1){3})/s';
$str = '-A
-AB
-ABC
-ABCD
-ABCDE
-ABCDEF';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);