import re
regex = re.compile(r"(?:(?:https?|ftp|file):\/\/|www\.|ftp\.)(?!yahoo)(?:\([-A-Z0-9+&@#\/%=~_|$?!:,.]*\)|[-A-Z0-9+&@#\/%=~_|$?!:,.])*(?:\([-A-Z0-9+&@#\/%=~_|$?!:,.]*\)|[A-Z0-9+&@#\/%=~_|$])")
test_str = ("Hello www.google.com World http://yahoo.com\n\n"
"https://www.google.com.tr/admin/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
"https://google.com.tr/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
"http://google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
"ftp://google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
"www.google.com.tr/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
"www.google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
"drive.google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")