use strict;
my $str = '울산동구울산 동구 문재2길 28 201호 (방어동,대호미주빌)대호미주빌201 호
울산광역시 동구 문재2길 28
서울 강서구 염창동 까치산로2가길 14 (뉴파인빌) 101호
서울특별시 강서구 까치산로2가길 14
울산동구울산 동구 방어진순환도로 1099 1603호 (서부동,신광그린파크)신광그린파크1603 호
울산광역시 동구 방어진순환도로 1099
울산남구울산 남구 대학로121번길 59 103동 613호 (무거동,무거현대아파트)무거현대아파트103
울산광역시 남구 대학로121번길 59
경기도안산시한양대학로5 -0 번지 한양대학교 엘지이노텍 안산R층
경기도 안산시 한양대학로 5
대구 중구 남성로 149 사랑모텔 2층2호
대구광역시 중구 남성로 149
경기 수원시 팔달구 덕영대로 지하 907-65 수원역지하상가 8호 폰앤폰2
경기도 수원시 팔달구 덕영대로 지하907-65
충북 청주시 상당구 수영로 328 장자마을현대아파트 204동102호
충청북도 청주시 상당구 수영로 328
경기도수원시장다리로1 번지 엠하우스1차303 호 엠하우스1차303 호
경기도 수원시 장다리로 1
경기도성남시정자일로177 -0 번지 인텔리지ⅡB 동3208 호
경기도 성남시 정자일로 177
경남창원시 성산구경남 창원시 성산구 원이대로 774 509동1006호
경상남도 창원시 성산구 원이대로 774
충청북도청주시안덕벌로 19번길88 -0 번지 우연빌206 호
충청북도 청주시 안덕벌로19번길 88
경남 김해시 내동 금관대로 1277번길 1-17 2층
경상남도 김해시 금관대로1277번길 1-17
서울특별시 강동구 천호동 천호대로157길 14번 8층
서울특별시 강동구 천호대로157길 14
광주 광산구 월계동 첨단2차호반아파트 211동 504호 /월계로59호반2차아파트
광주광역시 광산구 월계로 59
경상남도 창원시 마산회원구 내서읍 숲속로 27 603동1205호
경상남도 창원시 마산회원구 내서읍 숲속로 27
충청북도 청주시 상당구 중고개로 349 보성트윈힐스아파트 B동 1102호
충청북도 청주시 상당구 중고개로 349
경기도안산시초지2로 나인호텔67 -13 번지 나인호텔410 호13
경기도 안산시 초지2로 67-13
서울 구로구 구로동로18길 41 1층 명성지물장식
서울특별시 구로구 구로동로18길 41
서울특별시 강동구 양재대로 1340 주공아파트 024297206 215동 304호
서울특별시 강동구 양재대로 1340
서울특별시 구로구 구로중앙로31길 26 3층
서울특별시 구로구 구로중앙로31길 26
서울특별시 용산구 원효로1가 원효로81길 33 삼성맨션 102호
서울특별시 용산구 원효로81길 33
경상남도 창원시 마산회원구 내서읍 중리상곡로 18 1동1301호
경상남도 창원시 마산회원구 내서읍 중리상곡로 18
서울특별시 송파구 장지동 송파파인타운3단지아파트 306동 206호//충민로152/849번지/
서울특별시 송파구 충민로 152
경기도 수원시 장안구 조원동 한일타운아파트 108동 2403호/경수대로976번길22
경기도 수원시 장안구 경수대로976번길 22
서울특별시 동작구 노량진로23가길 16 102동 1603호
서울특별시 동작구 노량진로23가길 16
서울특별시 강남구 학동로 609 삼익아파트 12동 907호/서울특별시 강남구 청담동 134-21
서울특별시 강남구 학동로 609
대구광역시달서구달구벌대로1005 -0 번지 (호산동)
대구광역시 달서구 달구벌대로 1005
경상남도 창원시 마산합포구 3·15대로 90-1
경상남도 창원시 마산합포구 3·15대로 90-1
부산광역시 남구 용호동 대박타워 201호/동명로170번길56
부산광역시 남구 동명로170번길 56
경기도 화성시 우정읍 3.1만세로332번길 100-1
경기도 화성시 우정읍 3.1만세로332번길 100-1
서울특별시성동구서울숲 2길10 -0 번지 202 호
서울특별시 성동구 서울숲2길 10
서울 종로구 종로 347 롯데캐슬 천지인 지동 2710호
서울특별시 종로구 종로 347
서울 영등포구 63로 45 19동 67호
서울특별시 영등포구 63로 45
경기 화성시 동탄문화센터로 39 포스코더샾 316-1102
경기도 화성시 동탄문화센터로 39
경기도화성시동탄문화센터로39 -0 번지 동탄시범다은마을포스코더샵317 동1501 호
경기도 화성시 동탄문화센터로 39
대구 중구 종로 30 3층 이편한고시원 228호
대구광역시 중구 종로 30
서울 마포구 임정로 47-1 서울 마포구 임정로 47-1 402호
서울특별시 마포구 임정로 47-1
서울특별시 서초구 사임당로1길 13 서울특별시 서초구 사임당로1길 13/서울특별시 서초구 서초동 1546-3
서울특별시 서초구 사임당로1길 13
울산광역시 중구 유곡로 77 울산광역시 중구 유곡로 77 선경맨션 101동 1002호/울산광역시 중구 태화동 200-1
울산광역시 중구 유곡로 77
서울특별시 성동구 동일로 123 성동구 동일로123 (쌍용자동차)/서울특별시 성동구 성수동2가 19-2
서울특별시 성동구 동일로 123
서울특별시 관악구 남부순환로 1569-5 서울특별시 관악구 남부순환로 1569-5 101/서울특별시 관악구 신림동 1464-46
서울특별시 관악구 남부순환로 1569-5
서울특별시 동작구 흑석로 84 서울특별시 동작구 흑석로 84 208관 420호/서울특별시 동작구 흑석동 221
서울특별시 동작구 흑석로 84
울산광역시동구꽃바위 5길27 -0 번지 풍성비치타운1305 호
울산광역시 동구 꽃바위5길 27
충청남도천안시불당11로82 -0 번지 (불당동,대원칸타빌)607 동1202 호
충청남도 천안시 불당11로 82
서울특별시 송파구 거여동 거여아파트4단지 402동 1101호/양산로4길8거여4단지아파트
서울특별시 송파구 양산로4길 8
서울특별시성북구개운사 길 75 -25 번지 Cj international house 층
서울특별시 성북구 개운사길 75-25
서울특별시종로구인사동길12 -0 번지 (인사동,대일빌딩)
서울특별시 종로구 인사동길 12
경상남도창원시경남 창원시 마산회원구 내서읍 삼계10길 22 (삼계리,더-푸른아파트) 116동 202호
경상남도 창원시 마산회원구 내서읍 삼계10길 22
경상남도 창원시 마산회원구 내서읍 삼계10길 22
경상남도 창원시 마산회원구 내서읍 삼계10길 22
전라남도여수시전남 여수시 쌍봉로 219 202동 402호 (신기동,신기주공)신기주공2단지202 동402 호
전라남도 여수시 쌍봉로 219
경북 칠곡군 석적읍 동중리10길 20-11 (중리, 경혜빌) 507호
경상북도 칠곡군 석적읍 동중리10길 20-11
경북 칠곡군 석적읍 서중리7길 15 (남율리, 대교초등학교) 뒷건물 3층 3학년연구실
경상북도 칠곡군 석적읍 서중리7길 15
경북 칠곡군 석적읍 동중리10길 26-7 (중리) 토담채501호
경상북도 칠곡군 석적읍 동중리10길 26-7
서울구로구서울 구로구 디지털로31길 85 106동 304호 (구로동,구로두산위브아파트)구로두산위브아파트106 동304 호
서울특별시 구로구 디지털로31길 85
충북청주시 서원구충북 청주시 서원구 1순환로1137번길 79 914동 1402호 (분평동,주은아파트)주은아파트914 동1402 호
충청북도 청주시 서원구 1순환로1137번길 79
부산 남구 대연3동 : [상세주소] 대연동 유엔평화로 29번길 137
부산광역시 남구 유엔평화로29번길 137
세종특별자치시 세종특별자치시 새롬동 : [상세주소] 새롬동 새롬북로14 새뜸마을 310동 1205호
세종특별자치시 새롬북로 14';
my $regex = qr/(?<road>계변고개|[가-힣0-9]+거리\b|[가-힣]+[읍|면]\s?[가-힣0-9·.]+로\b|[가-힣]+[읍|면]\s?[가-힣0-9·.]+길\b|[가-힣0-9·.]+로\b|[가-힣0-9·.]+길\b)\s?(?<underground>지하|지하 )?(?<air>공중|공중 )?(?<num1>[0-9]{1,4})(?:-)?(?<num2>[0-9]{1,4})?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}