package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[abc][bac][cab]`)
var str = `aaa
bbb
ccc
abc
acb
bba
cac
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}