package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])$`)
var str = `05:10:36
23:59:59
00:00:00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}